My start-up location not working

  • I started using Windy on my laptop last year when i was living in Spain.
    I no longer live in Spain, but every time i open Windy it takes me to my old location in Spain.
    I have tried using GPS, IP address and i have set my current location as a favorite to set my start-up location, but it still takes me to a country i have not been to for nearly a year!!!
    Can anyone please help as its doing my head in!

  • | Premium

    I’m having a similar issue. When I click on the Windy widget in iOS I’m taken to 0.00/0.00 near Africa rather than my one and only location in favorites. Opening the app via icon works as intended but not via widget.

    I’ve tried logging out and back in. I also subscribed thinking that would fix it. I don’t mind paying for features but not when they’re broken.

    Hopefully this can be investigated.

    Thanks in advance.

  • Try resetting your account or try if you downloaded it try undownloading it an download it again

  • | Premium

    Thanks for the suggestion. I just tried deleting the app, reinstalling and logging back in. Exact same result. Clicking on the widget opens the app, starts at my favorite location and immediately pans the map to 0.00, 0.00. Opening the app via icon works as expected.

    At a minimum this shows I can replicate my own bug. Now it’s just a matter of figuring out why this is happening.

    Any other suggestions I’m all ears. Thank you.

  • | Premium

    Also as a data point I tried logging out, uninstalling the app, reinstalling and setting up the same favorite location without logging in. The same event happens and it pans to 0/0. So, I don’t believe it’s an issue with my account or saved data.

    I have location turned off and only allow it to use my favorite as a location. Since it’s going to 0/0 I wonder if it’s expecting a GPS signal and not getting one. The startup location is set to my favorite, not GPS.

    Hope that helps some.

  • | Premium

    GPS seems to be the issue. With location enabled in iOS Settings (which I never had to enable before) it opened to the correct location. Disabling location in Settings resulted in the erroneous pan to 0/0.

    It looks like the latest update to the app expects location services to be enabled. But, I don’t want my weather app following me around so I have it disabled.

    If anyone else wants to try replicating the above I can write step-by-step instructions.

    The TLDR method is to disable location in iOS Settings for the Windy app, then click on the widget. It should open and pan to 0.00, 0.00 rather than your preferred startup favorite. This assumes your startup location is a favorite and not IP or GPS.

  • | Premium

    Any input? I shouldn't have to have location services enabled for this widget to function. That's a privacy conflict at a minimum.

  • | Premium


    Certainly I can’t be the only one with this bug. I can replicate it with ease.

    Or, am I not posting in the correct location?

  • Administrator

    @foxtrotuniform Hello, thank you for reporting this bug. I was also able to replicate it and I have passed it to our development team, we will fix it.

  • | Premium

    @Korina Outstanding. Thank you!

  • Administrator

    @foxtrotuniform Hi, this will be fixed in the next update :)

  • | Premium

    @Korina Thank you! Both the startup location via widget and subscription bug appear to have been fixed. Very much appreciated.

Windyty, S.E. - all rights reserved. Powered by excellent NodeBB
NodeBB & contributors, OSM & contributors, HERE maps
Terms and Conditions     Privacy Policy