Status and future of Windy API



  • Windy is currently understaffed. We have absolutely minimum time to develop and maintain this API. No technical support will be provided from us.

    Sorry.

    We have great ideas that will make your work with Windy even more useful, and we are developing them right now.

    • Windy App is tied to Leaflet 7.7.x. We do not plan upgrade to Leaflet 1.x, because 7.7.x has smaller code base, is faster (in our opinions) and fulfils all our need.
    • API v2.0 runs on old renderer engine based on WIndyty client version 8.x.x. This renderer if very demanding on CPU and very slow. Only GFS model is available.
    • We plan new version API, that would be based on new super fast renderer from client v10.x and also Leaflet 7.7.x, but we have absolutely no time do to this right now.
    • We have absolutely no time or resources to make Windyty renderer open source library. The rendered contain a lot of custom Windyty code and is pretty much tied to very complex backend server (that is even more custom). We have no time.

    If you want to work for us as developer in Prague, we would be happy to have you in our team.


Log in to reply
 

Looks like your connection to Windy Community was lost, please wait while we try to reconnect.