Differences in weather in widget or app



  • The image shows the same location information within the app and from the widget. The rain drops look in different hours though?
    Any ideas why? Image here https://imgur.com/a/7RLp4
    Thanks

    alt text


  • administrators

    This is a bug



  • Just another more pronounced example of the same bug. https://imgur.com/a/XmMyj
    The raindrops are in the right pattern/grouping, just in the wrong position. It's going to rain all afternoon here from 3pm Tuesday. I've tried resizing, refreshing, and removing and re-adding the widget without success.
    Thanks for the great work on this app guys. Love it!

    alt text


  • administrators

    Looking into it



  • Installed the latest beta last night. Thanks. After coming out of airplane mode in the morning, the widget is like this https://imgur.com/a/gpZw3
    Clicking it does not open the app either?
    Cheers
    Neil



  • Quick update on the new version of the app.

    I still randomly see the widget go to a blank state with the message "Failed to retrieve forecast data."

    The phone is not in offline mode and was just in my pocket. I'm using a stock Nexus 5X with Android Oreo.
    When the widget is in this state it does not seem to recover when phone is awake. It is also unresponsive and no longer opens the app when pressed. The only workaround is to remove the widget and re-add it.
    If you have multiple instances of the widget on your phone, they all say "failed to retrieve forecast data" but you only need to remove and re-add one of them and the rest are fine again. Hope this helps. I'm on the beta builds so will install latest when available and keep an eye on it.
    Cheers

    Update: I left it for a few hours in the non responsive state and it did pick up the forecast and start working again by itself. :)

    Update 2: in the morning after coming out of airplane mode, the widget says "location not found" and is blank and unresponsive. Phone restart didn't change anything. Remove and add widget to solve.



  • "Failed to retrieve forecast data."
    Do you guys see this blank message daily on the widget too? Widget becomes black and unresponsive and won't open app.
    Adding and removing widget solves it. Or just wait a few hours and it might resolve itself and start showing the forecast again.

    Update: came back now by itself. I suspect that the widget tries to update overnight when the phone is in airplane mode and fails to get an update. It should just keep the older information in this scenario, but instead it gives an error and makes the widget unresponsive and unable to open the app.



  • I wasn't offline today and it still went from a good display to a blank "failed to retrieve forecast". Thks is the biggest obstacle to using the app daily. The widget is intermittent and is blank about half the time I look at it.


  • administrators

    There is version 12.32 out there make sure you have that. Then try to reinstall the app. Our Android programmer Milan watches this thread closely.



  • @ivo thanks Ivo. I was on 12.30. I've updated now and will find some feedback in a day or too.
    Thanks for the great support.


  • administrators

    It is always good to send screenshots. If you resize image to smaller one you can upload them directly here



  • Some quick feedback on 12.32

    0_1509526028140_1.jpg
    0_1509526037944_2.jpg

    The widget in image 1 shows my current location. when I click the widget, it opens up image 2. A location 30km away from current location - a location where I was last night. So the bug is that the app is not opening up to current location as displayed on the widget. It is opening up to a previous location.

    Also, sometimes the Widget location text remains blank when I move to a new location. I click the refresh icon on the widget and the weather updates, but the location text remains blank. (I didn't get an image of this, sorry).
    After 10 or 15 minutes, another refresh, and this time it filled in the location text "Tallaght-Fettercairn ED".

    I have not seen any forecast not found blank errors with this update. Widget always shows something, and always launches the app. This is great.

    Thanks :)



  • 0_1509567278988_Screenshot_20171101-201218-picsay.png

    Another issue I noticed is that the widget on one of my phone screens is stuck in a refresh loop. The refresh icon constantly spinning. I have the widget on another page on the phone and it's fine. You click refresh and it refreshes and stops spinning. Not sure how this one got stuck in the loop like this. I removed it and added it again to resolve.



  • First instance I have seen of this issue in 12.32.
    0_1509658836174_Screenshot_20171102-213837-picsay.png
    Nexus 5x Oreo 8.1



  • Using 12.34 but still see the issues updating the widget. Sometimes location cannot be found, other time the refresh wheel in the top right of widget just remains spinning. Need to remove and add widget again to address the issue.
    Sometimes I note the temperature is way off compared to reality. It's just a case of the app hasn't refreshed correctly.
    Love the app. When widget issues solved, it will be the best. :)


Log in to reply
 

Windyty, S.E. - all rights reserved. Powered by excellent NodeBB
NodeBB & contributors, OSM & contributors, HERE maps

Looks like your connection to Windy Community was lost, please wait while we try to reconnect.