windy-plugin-skewt now running with ECMWF data



  • Version 0.2.0 is done! The skewT plugin now runs with ECMWF data. Use the picker to open a skewT and explore the world's profiles :)

    This version is still a little buggy I'm afraid (mostly the wind barbs), but I'll publish a few fixes soon. It's also slower than I'd like. Two things that would really help me for the next version are

    1. Is there a simple way to get surface pressure? I've tried getting it from the "forecast" method of pluginDataLoader, but using both this and "airData" together seems to grind everything to a halt. Right now the plugin just uses 1000hPa as the surface, which is far from ideal. Any chance someone @Windy could add surface pressure into the "airData" on the backend?

    2. Is there an API call that is sensitive to user changes in the time slider? Right now you have to move the picker after changing the date/time, or the plugin can't reload itself. Couldn't find anything in the API docs that could do this.

    Cheers!
    John

    @ivo @rittels @Gkikas-LGPZ


  • Administrator

    @johnckealy Ad 1) this must be bug in pluginDataLoader. I will check. Does it produce some error?

    Ad 2)

    import store from 'store'
    
    store.on('timestamp', ts => {
      console.log('New ts is', timestamp)
    })
    


  • @ivo thanks for the info. It turned out to be quite trivial :)

    The timestamp call works a treat. With the loader: no, there was no error, but I was embedding one load statement within the other which was probably a bad idea. I found a better approach by looping through the forecast keys and creating a time series array of surface pressure. Works nice now.

    I also added a call to store.get('product') so that I could load the current model, and I think I've found a bug on your end. If you change model from ECMWF to GFS and vice versa, the output of store.get('product') shows the old model. You have to move the picker before it will show the highlighted model.

    One other thing: how can I get the latest version to show in the plugin loader? If you enter windy-plugin-skewt you get version 0.1.0, the first version. You have to enter windy-plugin-skewt@0.2.5 to get the correct one. Obviously, this isn't a windy thing, it's to do with unpkg and npm. But any idea how to fix it? Npm shows me the latest version on its website, but I have to add the version number in unpkg.com to get the right one.



  • @johnckealy :
    You have to enter windy-plugin-skewt@0.2.5 to get the correct one. -Thx!!!
    takes about a day to update



  • Haha thanks @rittels! Seems the only issue was my impatience. It's working now. :)




Log in to reply
 

Windyty, S.E. - all rights reserved. Powered by excellent NodeBB
NodeBB & contributors, OSM & contributors, HERE maps