Report your Weather Station Data to Windy


  • Banned

    This post is deleted!


  • Dear support,
    yesterday I set up my first station with ID: f067927b
    Data upload is through cURL POST command in my Ubuntu server every 5 minutes.
    Posted data are in JSON format, response code from server is 200.

    When I want to see the data, nothing loads up:
    https://www.windy.com/station/pws-f067927b?50.492,13.755,8,i:pressure

    If I select any nearby location a click on nearest stations, my station is not listed too.

    Can you please give me some advice? Thank you in advance!
    Regards!
    Ondrej

    Update: When I download all stations data from the link "https://stations.windy.com/pws/stations/API-KEY", I see that my station have "observations" element set to "null". Please help!

    Update 2: I created a new station with ID: 1, redirected sending to that station and still no data with observations "null" element. Finally I decided to delete the new station and reverted sending back to station ID: 0. After 10 minutes, the observations started to WORK and showing past measurements too! GREAT! But I do not know where was the problem :-/


  • Administrator

    @damien66
    Hello Ondrej,
    you station is sending data correctly now, you could have had a mistake in station ID, instead of f067927b, you need to put '0' or '1' as the number of your station.



  • Windy Support,

    I just set up my station (f07efd5e) a couple of hours ago. I can see at stations.windy.com that my data is uploading. However, when I attempt to see my station on the Windy map at https://www.windy.com/station/pws-f07efd5e?32.295,-95.243,8,i:pressure, I'm able to see my Madis reporting station, but not the PWS station as I would expect. Also, the bottom quarter of the screen where meteograms and station info are displayed is just white with a spinning circle.

    Any idea why this is happening? Is it because I have only a couple of hours of data?

    Thanks.



  • I have created a small PowerShell script that sends data to the GET URL. But I am having trouble with the precip parameter. The reason is that this parameter is "preciptation over the past hour". Hmm. That is difficult to calculate without some programming. Why not just get precipitation as an absolute number of mm / inches since 1st January 00:00? Then you can, yourself, calculate the amount for the last hour or whatever period you want. I assume you collect data and stores to a database and then it will be easy for you to calculate this value.

    Suggestion: Parameter absprecip = 0.0 at 1st January 00:00 UTC and then increasing as an absolute value until 31st December 23:59:59... :-)

    Will that be possible.

    Regards,
    Roland Lyngvig
    Hillerød Vejr
    Denmark
    www.hilleroed-vejr.dk



  • I write a shell script to upload the station date, but look like it doesn't support the time format like "2020-02-19T21:40:00+08:00". Although it expressed as ISO 8601.

    + python -c import sys, json; actualObservTimes = json.load(sys.stdin)['actualObservTimes']; space = ' '; addSpace = list(actualObservTimes); addSpace.insert(8, space); print ''.join(addSpace)
    + Time=20200219 2140
    + date --date=20200219 2140 --iso-8601=seconds
    + ISOTime=2020-02-19T21:40:00+08:00
    + curl https://stations.windy.com/pws/update/$MyAPI?wind=0.8&mbar=1027&temp=8.1&&humidity=72&precip=0&time=2020-02-19T21:40:00+08:00&stationId=1
    SUCCESS (partial) <br /> invalid measurement values: 'time': 2020-02-19T21:40:00 08:00;
    

    Maybe I should upload as unix timestamp. Also easy to convert : date --date="20200219 2140" "+%s" :-)





  • There is a python script to calculate dewpoint: https://www.meteo-blog.net/2012-05/dewpoint-calculation-script-in-python/ :-)



  • I wonder if possible to remove the error data. I thought pressure is hpa, now I use mbar:-/



  • @SteveFitz1 I had to delete station, recreate it and then were the data displayed.



  • @jdjeff58 said in Report your Weather Station Data to Windy:

    I got my station up and running through Weather Display Software (ID: f06afffe). But there are some things I don't understand when viewing this website on my desktop PC.
    1.I have to select "nearest weather stations" to bring up a box with all the nearby stations. I found my station and set it as a favorite. Why is there a message on my station banner at the bottom of the weather map that says "There is duplicate station D5731?
    2. When setting up the station it is not clear what station ID is supposed to be. I first set mine to "Exeter". But I see all other stations nearby are using the format like the duplicate station D5731 Where are they getting these ID's? I just made up a number since then and now it's called "D2657: Exeter". Is this what everyone else is doing? Just making up ID's? My f06afffe doesn't seem to have this letter followed by 4 number format.
    3. If I set my station as my startup page, it always starts up zoomed out showing entire US. If I zoom in I see the last number in the URL changes from 5 to 8. If I save my bookmark with 8 at the end to start up zoomed in, it reverts to 5 zoomed out when I reload the page. If I change the start up location to GPS, it will save my last zoom value 8 but now centers on the flashing ISP dot. And how do I get rid of the flashing dot showing my ISP location (IP address origin)?

    Geez...I'm not even sure how I found my way in this thread.


  • Administrator

    @Namibia2007
    Hello,
    did you create two stations? Since f06afffe does not show any data nor is displayed on Windy. However D5731 does share data without any problem.

    Please enclose a screenshot of this message - "There is duplicate station D5731".

    You can bookmark your station view with zoom in level 8, however if you reload page again, it will go back to the default zoom 5.

    Thank you.



  • I see visibility parameter from station API. But I didn't see the information about visibility. If is available for update API? And what's its unit, kilometers or miles?



  • Dear support,

    is the "Info Part Parameters" section of the first post here still actual?
    On 8.3.2020 at 13:00 I started getting this reply from server after data upload:

    Station 0 issues: invalid station info params: 'name'
    

    Windy server responds with successful code 200, but with this message.
    As the 'name' parameter is optional, I have removed it from the uploading data and it works fine now.

    Please keep the upload protocol updated.
    Thank you for your great services :-)
    Regards
    Ondrej



  • This post is deleted!


  • This post is deleted!

  • Banned

    This post is deleted!


  • This post is deleted!

Log in to reply
 

Windyty, S.E. - all rights reserved. Powered by excellent NodeBB
NodeBB & contributors, OSM & contributors, HERE maps