Report your Weather Station Data to Windy



  • I wonder if possible to remove the error data. I thought pressure is hpa, now I use mbar:-/



  • @SteveFitz1 I had to delete station, recreate it and then were the data displayed.



  • @jdjeff58 said in Report your Weather Station Data to Windy:

    I got my station up and running through Weather Display Software (ID: f06afffe). But there are some things I don't understand when viewing this website on my desktop PC.
    1.I have to select "nearest weather stations" to bring up a box with all the nearby stations. I found my station and set it as a favorite. Why is there a message on my station banner at the bottom of the weather map that says "There is duplicate station D5731?
    2. When setting up the station it is not clear what station ID is supposed to be. I first set mine to "Exeter". But I see all other stations nearby are using the format like the duplicate station D5731 Where are they getting these ID's? I just made up a number since then and now it's called "D2657: Exeter". Is this what everyone else is doing? Just making up ID's? My f06afffe doesn't seem to have this letter followed by 4 number format.
    3. If I set my station as my startup page, it always starts up zoomed out showing entire US. If I zoom in I see the last number in the URL changes from 5 to 8. If I save my bookmark with 8 at the end to start up zoomed in, it reverts to 5 zoomed out when I reload the page. If I change the start up location to GPS, it will save my last zoom value 8 but now centers on the flashing ISP dot. And how do I get rid of the flashing dot showing my ISP location (IP address origin)?

    Geez...I'm not even sure how I found my way in this thread.


  • Administrator

    @Namibia2007
    Hello,
    did you create two stations? Since f06afffe does not show any data nor is displayed on Windy. However D5731 does share data without any problem.

    Please enclose a screenshot of this message - "There is duplicate station D5731".

    You can bookmark your station view with zoom in level 8, however if you reload page again, it will go back to the default zoom 5.

    Thank you.



  • I see visibility parameter from station API. But I didn't see the information about visibility. If is available for update API? And what's its unit, kilometers or miles?



  • Dear support,

    is the "Info Part Parameters" section of the first post here still actual?
    On 8.3.2020 at 13:00 I started getting this reply from server after data upload:

    Station 0 issues: invalid station info params: 'name'
    

    Windy server responds with successful code 200, but with this message.
    As the 'name' parameter is optional, I have removed it from the uploading data and it works fine now.

    Please keep the upload protocol updated.
    Thank you for your great services :-)
    Regards
    Ondrej



  • This post is deleted!


  • This post is deleted!

  • Banned

    This post is deleted!


  • This post is deleted!

  • Administrator

    @tomacat Hi, if you mean sharing visibility data from your station, it is not possible on our end.



  • Hi. Two questions.

    First, I have been pushing up the weather to Windy every 7 minutes since yesterday afternoon...maybe 15 hours straight? But still no data showing here:

    https://www.windy.com/station/pws-f065e403?38.972,-94.647,8

    I am using this below to send the data per the GET param example above, and I know for a fact it is working perfectly as I am getting responses (e.g., when I sent a few too quickly under 5min, it told me that). Here it is:

    https://stations.windy.com/pws/update/--MyAPIKey--?winddir=46&windspeedmph=1.0&windgustmph=6.0&tempf=41.3&rainin=0.00&baromin=29.01&dewptf=29.7&humidity=63

    Second, FYI that in your Get example in the post above, you include "&dewptf=68.2&humidity=90", however these two parameters are not listed in the parameter list in the same post. Is there a more up-to-date API documentation? Are those correct? Are there others?

    Thanks! Love, LOVE Windy!

    Greg



  • I thought I'd add that the site DOES show it under the stations. See the screenshot below. AND it shows it is updating. In this example, 4 minutes ago. But no data is shown.

    444bb9c8-2938-4697-b15c-ccfacb803d2f-image.png

    0725c227-5097-4378-9c3c-1500009fe157-image.png



  • @TomSlavkovsky Hi Tom. Just pinging you on this post as I think I may have not replied to the right one (my first time using this forum) and wanted to make sure it is seen. 😬 Thanks in advance!





  • Lastly, here is what I get when I retrieve my data. Per below, observation data is null...

    {"header":{"name":"Round Hill, Overland Park, KS","content":{"url":"","text":"FayIronmanWS"},"agl_temp":10,"agl_wind":10,"elev_m":322.48,"lat":38.970556,"lon":-94.649167,"stationType":"Davis Vantage Pro 2","shareOption":"Open","id":"f065e403","stationId":0,"type":"pws","updated":"2020-04-16T08:00:53.479Z","observation":{"avgFreqMin":7.231182795698925,"records":1,"avgDelayMin":5,"sumRows":186,"default":false,"latestObs":"2020-04-15T21:41:34.902Z"},"observationUpdated":"2020-04-15T21:41:34.902Z"},"data":null}



  • @Korina Hi, any thoughts on the above issue? Seems I'm doing everything right?! Thanks in advance!


  • Administrator



  • @Korina Hi! Thanks for the reply. I used Weathersnoop on a Mac Pro, and wrote an Applescript to push up the data every 7 minutes:

    tell application "WeatherSnoop 5"
    tell agent of first document
    set MyAPIKey to "MyAPIKey"
    set WeatherParams to ¬
    "winddir=" & value of weather property "Wind Direction" & ¬
    "&windspeedmph=" & value of weather property "Wind Speed" & ¬
    "&windgustmph=" & value of weather property "10 Minute Wind Gust" & ¬
    "&tempf=" & value of weather property "Outdoor Temperature" & ¬
    "&rainin=" & value of weather property "Day Rain" & ¬
    "&baromin=" & value of weather property "Barometric Pressure (Absolute)" & ¬
    "&dewptf=" & value of weather property "Outdoor Dew Point" & ¬
    "&humidity=" & value of weather property "Outdoor Humidity"
    set WindyURL to "curl https://stations.windy.com/pws/update/" & MyAPIKey & "?" & WeatherParams & "&stationId=0"
    set WindyURLsafe to "https://stations.windy.com/pws/update/" & "MYAPIKEY" & "?" & WeatherParams & "&stationId=0"
    set myResult to do shell script WindyURL
    end tell
    end tell
    set myTime to do shell script "date "
    set myString to "----------Timestamp: " & myTime & "-----------" & linefeed & WindyURLsafe & linefeed & myResult
    copy myString to stdout

    It's been running every 7 minutes for quite a while now. It sure seems like it's working! Here is the output from a few minutes ago:
    ----------Timestamp: Fri Apr 17 08:18:35 CDT 2020-----------
    https://stations.windy.com/pws/update/MYAPIKEY?winddir=333&windspeedmph=3.0&windgustmph=9.0&tempf=34.1&rainin=0.42&baromin=28.97&dewptf=33.1&humidity=96&stationId=0
    SUCCESS

    ...and it sure looks like it's getting there!?
    92cc4606-71d2-4295-8739-63acc9f96202-image.png

    Thanks for your help. :)

    Greg



  • @Korina Hi. Any thoughts on this? It seems to be posting perfectly. I am posting every 7 minutes now for a week. I get "SUCCESS" responses and other messages (e.g., if trying to do less than the 5 minutes). The site shows the updates are happening per the image above. But no data is being shown...I get the error in the screenshot in the post above.

    I'd think if this can be resolved, it could be a great, easy solution that I could write up for all Weathersnoop users to be able to push up their weather station data! I am familiar with the wifi logger but it would conflict with Weathersnoop which is very powerful and customizable.

    I'm a premium member. Can you or someone help me out, please? Thanks! I love Windy! :)

    Greg


Log in to reply
 

Windyty, S.E. - all rights reserved. Powered by excellent NodeBB
NodeBB & contributors, OSM & contributors, HERE maps
Terms and Conditions     Privacy Policy