Report your Weather Station Data to Windy



  • @galfert My station was bought from here link text

    I used the term "similar to" as there are no other stations with a model number like that that I could find on international sites.

    I am not sure what software is on the station, but i do not use any intermediary software. The station connects to my wifi and the data gets uploaded.

    But I guess you have answered my question. I won't be able to upload data to windy.


  • Meteorologist

    @Phillip1511 Your station hardware is built by Fine Offset. It is an HP1000 based system.
    http://www.foshk.com/Wifi_Weather_Station/HP1000.html

    This is nothing like an Acurite. It is as I said though like an Ambient since Ambient is among the most recognizable reseller brands from Fine Offset which people often call Ambient clone or Fine Offset clone when it isn't an actual Ambient. You'll probably find a lot of information if you search the Internet for the equivalent Ambient model to your station which is one of several of these in order of release; WS-1000, WS-1001, and the latest is WS-1002
    https://www.ambientweather.com/amws1000wifi.html

    Now that we know what you have I can recommend a solution. There are actually several solutions to upload to Windy. But since you said that technology was not your strong point I will recommend the least technical solution first....which is not lesser in any way as it is a very complete solution that will enable your system to not just upload to Windy but you can upload to many many other weather services all simultaneously including; Weather Underground, CWOP, AWEKAS, PWSweather, WeatherCloud, MetOffice WOW, OpenWeatherMap, AmbientWeather.net, Ecowitt.net and even more...including to your own personal website with custom templates or your own scripts.

    Here is the solution that you'll need:

    • Ecowitt GW1000 with 433 MHz frequency to match your current station
    • Ambient WeatherBridge. Not sure if you'll be able to purchase this from Ambient. If you can't then you can purchase a TP-Link (be sure to get not just the right model but also version) and then install the Meteobridge software. If you can get a WeatherBridge that is easier as its already installed and licensed. The Do-it-yourself Meteobridge requires separate license.

    Essentially what happens with this extra hardware/software is that the GW1000 reads your outdoor sensor (temp/hum/rain/wind...etc). and then passes it along to the Meteobridge. It is the Meteobridge device with its software that then lets you upload data to a multitude of places.

    If you want a cheaper alternative solution:

    • Install WeeWx on a Raspberry Pi or spare computer....better to use the Pi though. Then using the WeeWx add-on Interceptor driver you can capture the data from your station. Then WeeWx can send to Windy and to a multitude of other weather services similar to the Meteobridge.
    • As an alternative you can also get the GW1000 (without Meteobridge) to facilitate getting the data to the WeeWx.

    So this is totally doable. I suggest if you need help to visit the wxforum.net for further help. If you post there, numerous people are available to help answer your questions.



  • Hi!
    Iam trying to post my data to windy from Debian PC using WGET and GET Param method...
    When i put temp=value param, it is accepted (SUCCESS) and displayed (https://www.windy.com/station/pws-f06c5d57?radar,49.719,13.239,8) by WINDY.
    Same result for rh=value. (So my API key, connection, method.... should be all O.K.)
    But when i try to send "temp=value&rh=value" by the same way, request is accepted (SUCCESS) but only temp is displayed on web (station page URL above or getting data using json)...

    What can be wrong?
    Are params all required or in some spec. order e.g.?

    THX!

    Martin


  • Meteorologist

    @steinham Try using &humidity=value instead of &rh=value.



  • @galfert said in Report you Weather Station Data to Windy:

    &humidity=

    THX for that tip, but i did it already with same result... :/ Only able to put temp and wind params together. All others (rh/humidity, gust, winddir, dewpoint, mbar and precip) remains "blank" (null if try to get data back using WINDY API)...

    I did not check which of them i am able to submit alone - maybe good homework for tonight... :-)

    M.



  • @TomSlavkovsky Hello,thank you for a great weather station.I have tried to contact someone responsible for your system of identifying country’s.I live in Antigua in the Caribbean ,St Johns is our capital.I cannot tell you more than three of my close islands capitol much less know which island is going to be hit by a hurricane.Why do you put the towns name to identify the country and not their NAMES like ANTIGUA!???I,like most people ,don’t like it ,I don’t want to play guessing games when I am worried or concerned about where the hurrican may or will striking..Please change it to the country’s names..The average person are not sophisticated enough to know towns.I hope you take a moment to think about it.Thank You .Alma


  • Sailor



  • I got my station up and running through Weather Display Software (ID: f06afffe). But there are some things I don't understand when viewing this website on my desktop PC.
    1.I have to select "nearest weather stations" to bring up a box with all the nearby stations. I found my station and set it as a favorite. Why is there a message on my station banner at the bottom of the weather map that says "There is duplicate station D5731?
    2. When setting up the station it is not clear what station ID is supposed to be. I first set mine to "Exeter". But I see all other stations nearby are using the format like the duplicate station D5731 Where are they getting these ID's? I just made up a number since then and now it's called "D2657: Exeter". Is this what everyone else is doing? Just making up ID's? My f06afffe doesn't seem to have this letter followed by 4 number format.
    3. If I set my station as my startup page, it always starts up zoomed out showing entire US. If I zoom in I see the last number in the URL changes from 5 to 8. If I save my bookmark with 8 at the end to start up zoomed in, it reverts to 5 zoomed out when I reload the page. If I change the start up location to GPS, it will save my last zoom value 8 but now centers on the flashing ISP dot. And how do I get rid of the flashing dot showing my ISP location (IP address origin)?

    Geez...I'm not even sure how I found my way in this thread.


  • Clima España

    @markdj pues yo tengo una netatmo y la he podido poner sin problema,lo unico que no se ven los datos del pluviómetro,del resto si


  • Clima España

    5D710A91-19C4-445C-9C1A-540786F222FA.jpeg


  • Clima España

    This post is deleted!


  • Hi there!
    I have a Netatmo account with two stations far apart. How can I include both of them on Windy? So far when I've tried it displays only one of them and there is no way to see both or even to choose which one I want to post data from. Thanks.



  • Support for pywws-supported stations is also coming https://github.com/jim-easterbrook/pywws/pull/89

    My station is reporting through that for some hours now https://www.windy.com/station/pws-f06b410b


Log in to reply
 

Windyty, S.E. - all rights reserved. Powered by excellent NodeBB
NodeBB & contributors, OSM & contributors, HERE maps