Meteobridge added support to share data on Windy



  • Meteobridge added support to send data to Windy. The setup of Meteobridge is very easy. Just go to the tab Weather Networks and choose from the dropdown list Windy.com. Insert your Windy Station API key, which you can generate on Windy Stations website.

    Note: you need to your MeteoBridge firmware to have Windy in Weather Networks tab.

    800px-Windy.png


  • Meteorologist

    DON'T USE THIS METHOD YET
    UPDATE: Meteobridge has been patched and now uploads to Windy without issues.

    I just changed from using the HTTP method in my Meteobridge to use this simpler setup. It messed up my barometric pressure graph. Seems the Meteobridge is sending hPa but Windy is receiving it in Pa. This is messing up a lot of other people with other weather software too (Cumulus and Weather-Display) when they attempt to send hPa which is more traditional. I know Windy clearly has this documented that it is supposed to be sent in Pa and not hPa but I guess it is an easy oversight for the programmers of these software programs as it is not expected. Windy should update and fix Pressure to be hPa or come up with a new tag called baromhPa.

    Now I have bad data in my Windy station and I have no way to get rid of it. I tried deleting my station. I checked and it was gone on the map too. Then I created what I thought would be a new station...but no...the same old station came back with the same API key and all the bad data.

    Windy please provide us a way to get rid of bad data.
    Windy Bad Data.jpg

    For now I'm back to using the HTTP upload method with my Meteobridge where I can use baromin and send inHg for pressure. I just wish my pressure graph gets fixed as it is useless now because it is a flat line.
    https://www.windy.com/station/pws-f075acbe?28.677,-81.241,8,i:pressure



  • Hello,
    I wonder that my Meteobridge is not showing Windy on the long list of weather stations I only have Wind finder and Wind Guru?! Do I have to reset the Meteobridge or how does it show up ? When it shows up do I have to put in my ID which is nine numbers/ciphers long or do I have to put in the very long API number???

    Thank you for your information!
    Edward



  • @Meteoplug You need to update your MeteoBridge firmware for the windy option to show up.



  • @galfert we will add a new parameter to the API soon.
    @Medart



  • @galfert For the life of me I can't figure out how to see ANY weather stations on Windy.com or the Android app?

    I see nothing in the layer settings to show PWS.


  • Meteorologist

    @Meteoplug
    To get the latest Meteobridge software update a few things need to be in place.
    1- You need to be sure your Meteobridge license is current. It expires every 2 years. You won't get updates if it isn't current.
    2- You need to set the Meteobridge version control drop down in the System tab to be get newest on boot.
    3- Then you need to reboot the Meteobridge to have it update to the latest version.

    Now you will see Windy in the Weather Network tab.
    All you need to do is enter in the long Windy API key and click Save at the bottom.

    ** But don't do this yet. Pressure is not working right. as you can see from my previous post.
    UPDATE: Meteobridge Windy upload has been patched and now works great.



  • @galfert
    thanks very much for your help - everything worked fine. License is current -newest on boot and updated. I have put in my API key and meteobridge shows green light. How long does it takes until it will get my data ??

    regards,
    Edward



  • @Meteoplug you should seem them by now.



  • A new update was just released by meteobridge that addressed this issue and should work with both the galfert's HTTP or meteobridges Weather Network method

    Andy



  • Hello,With meteobrigde

    Weather Network Status success the last 24 hours

    2019-05-27 20:14:06 Success: 2019-05-27 20:13:23
    2019-05-27 20:08:52 Success: 2019-05-27 20:08:13
    2019-05-27 20:03:43 Success: 2019-05-27 20:03:04
    2019-05-27 19:58:17 Success: 2019-05-27 19:57:50
    2019-05-27 19:53:10 Success: 2019-05-27 19:52:39
    2019-05-27 19:47:57 Success: 2019-05-27 19:47:29
    2019-05-27 19:42:48 Success: 2019-05-27 19:42:18
    2019-05-27 19:37:50 Success: 2019-05-27 19:37:09
    2019-05-27 19:32:27 Success: 2019-05-27 19:31:59
    2019-05-27 19:27:29 Success: 2019-05-27 19:26:49
    2019-05-27 19:22:10 Success: 2019-05-27 19:21:31.......

    But when I check the map....Station xxxxx does not report any observations for given time period or we were unable to retrieve them

    Anybody can help please
    Thanks



  • @Eguraldia send me please your station ID, I will check it. Thanks



  • @TomSlavkovsky I send you a email few hours ago.
    Thanks



  • I check few times the whole key and copy and paste its ok and still nothing....live data in meteobridge working fine

    2019-05-30 17:26:33 Success: 2019-05-30 17:25:48
    2019-05-30 17:21:19 Success: 2019-05-30 17:20:30
    2019-05-30 17:15:53 Success: 2019-05-30 17:15:20
    2019-05-30 17:10:54 Success: 2019-05-30 17:10:10
    2019-05-30 17:05:54 Success: 2019-05-30 17:05:00
    2019-05-30 17:00:18 Success: 2019-05-30 16:59:46
    2019-05-30 16:55:23 Success: 2019-05-30 16:54:36
    2019-05-30 16:49:55 Success: 2019-05-30 16:49:26
    2019-05-30 16:45:17 Success: 2019-05-30 16:44:26
    2019-05-30 16:39:56 Success: 2019-05-30 16:39:14
    2019-05-30 16:34:45 Success: 2019-05-30 16:34:04
    2019-05-30 16:29:21 Success: 2019-05-30 16:28:50
    2019-05-30 16:24:31 Success: 2019-05-30 16:23:40
    2019-05-30 16:19:10 Success: 2019-05-30 16:18:30
    2019-05-30 16:14:11 Success: 2019-05-30 16:13:22
    2019-05-30 16:08:48 Success: 2019-05-30 16:08:22
    2019-05-30 16:03:45 Success: 2019-05-30 16:03:13

    And still not report of my station......



  • I just create another account and working fine and delete the other



  • Like @Eguraldia1 ... I have setup my API and added to Meteobridge. Meteobridge is reporting 'success' that the data has reached the Windy server, but when I look at my station - there's no data at all. Have sent a message to @TomSlavkovsky separately, awaiting reply.


Log in to reply
 

Windyty, S.E. - all rights reserved. Powered by excellent NodeBB
NodeBB & contributors, OSM & contributors, HERE maps