@edbradburn

The Radar layer shows this pulsing blue dot at your assumed location.
Try to change your location setting.
In Settings -> Start-up location
I see that you have selected your location as favorite. Try to use it as start-up location.

7F33CA4F-FD31-4A81-9D39-4F8849066B01.jpeg