@jhnelson24 Hi, this is not a bug, since on Radar layer you don't even have an option to have isobars turned on. Instead there is Lightning and sound, please see below - Isobars are not in settings, so they cannot be saved as default.