@johnfmejia Hi, it can happen. Interpolation algorithm is not able to detect motion correctly in all cases. Problems can occur especially when multiple layers of clouds are present or when small clouds are quickly appearing or disappearing. If it is your case, please try to turn-off "Smooth satellite animation" in the settings.