@Paulo-Roberto-D-Santos-Bolarinho Hi, the 3D globe might be a little more hardware-demanding on older devices. I suggest using the Graphic compatibility mode in the settings.