UPDATE: Problem solved. The second parameter should be an offset, not a page number.