Hi @Sidepeek have you tried to check your phone settings, maybe you didn't allow it there